Our Apps runs on any devices running Android and iOS operating system subject to the support given by the OS provider.

  • Android phones
    The minimum Android OS version needs to be version 6 or above, phones with version below 6.0 will not be able to find our app in the google play store. This is the requirement from Google.

  • IOS phones
    You will need at least iOS version 8 and above, any apple mobile devices running iOS version below 8.0 will not find the App in the App store.